Out-of-bounds Read Affecting openjpeg2 package, versions <2.4.0-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.61% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-OPENJPEG2-21751305
  • published27 Oct 2026
  • disclosed13 May 2021

Introduced: 13 May 2021

CVE-2020-27824  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Echo:latest openjpeg2 to version 2.4.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openjpeg2 package and not the openjpeg2 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

A flaw was found in OpenJPEG’s encoder in the opj_dwt_calc_explicit_stepsizes() function. This flaw allows an attacker who can supply crafted input to decomposition levels to cause a buffer overflow. The highest threat from this vulnerability is to system availability.

CVSS Base Scores

version 3.1