Insufficient Verification of Data Authenticity Affecting packagekit package, versions <1.2.1-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.34% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PACKAGEKIT-19665950
  • published10 Sept 2026
  • disclosed7 Nov 2020

Introduced: 7 Nov 2020

CVE-2020-16122  (opens in a new tab)
CWE-345  (opens in a new tab)

How to fix?

Upgrade Echo:latest packagekit to version 1.2.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream packagekit package and not the packagekit package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

PackageKit's apt backend mistakenly treated all local debs as trusted. The apt security model is based on repository trust and not on the contents of individual files. On sites with configured PolicyKit rules this may allow users to install malicious packages.

CVSS Base Scores

version 3.1