Cross-site Request Forgery (CSRF) Affecting pcs package, versions <0.9.149-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.46% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PCS-19683743
  • published11 Sept 2026
  • disclosed21 Apr 2017

Introduced: 21 Apr 2017

CVE-2016-0720  (opens in a new tab)
CWE-352  (opens in a new tab)

How to fix?

Upgrade Echo:latest pcs to version 0.9.149-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcs package and not the pcs package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

Cross-site request forgery (CSRF) vulnerability in pcsd web UI in pcs before 0.9.149.

CVSS Base Scores

version 3.1