Information Exposure Affecting pcs package, versions <0.9.164-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.92% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PCS-19683747
  • published11 Sept 2026
  • disclosed12 Apr 2018

Introduced: 12 Apr 2018

CVE-2018-1086  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Echo:latest pcs to version 0.9.164-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcs package and not the pcs package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

pcs before versions 0.9.164 and 0.10 is vulnerable to a debug parameter removal bypass. REST interface of the pcsd service did not properly remove the pcs debug argument from the /run_pcs query, possibly disclosing sensitive information. A remote attacker with a valid token could use this flaw to elevate their privilege.