Incorrect Default Permissions Affecting pcs package, versions <0.11.3-2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.32% (25th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PCS-19683749
  • published11 Sept 2026
  • disclosed6 Sept 2022

Introduced: 6 Sep 2022

CVE-2022-2735  (opens in a new tab)
CWE-276  (opens in a new tab)

How to fix?

Upgrade Echo:latest pcs to version 0.11.3-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcs package and not the pcs package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

A vulnerability was found in the PCS project. This issue occurs due to incorrect permissions on a Unix socket used for internal communication between PCS daemons. A privilege escalation could happen by obtaining an authentication token for a hacluster user. With the "hacluster" token, this flaw allows an attacker to have complete control over the cluster managed by PCS.

CVSS Base Scores

version 3.1