CVE-2023-45805 Affecting pdm package, versions <2.20.0.post1+ds1-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.45% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PDM-18533229
  • published5 Aug 2026
  • disclosed20 Oct 2023

Introduced: 20 Oct 2023

CVE-2023-45805  (opens in a new tab)

How to fix?

Upgrade Echo:latest pdm to version 2.20.0.post1+ds1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pdm package and not the pdm package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

pdm is a Python package and dependency manager supporting the latest PEP standards. It's possible to craft a malicious pdm.lock file that could allow e.g. an insider or a malicious open source project to appear to depend on a trusted PyPI project, but actually install another project. A project foo can be targeted by creating the project foo-2 and uploading the file foo-2-2.tar.gz to pypi.org. PyPI will see this as project foo-2 version 2, while PDM will see this as project foo version 2-2. The version must only be parseable as a version and the filename must be a prefix of the project name, but it's not verified to match the version being installed. Version 2-2 is also not a valid normalized version per PEP 440. Matching the project name exactly (not just prefix) would fix the issue. When installing dependencies with PDM, what's actually installed could differ from what's listed in pyproject.toml (including arbitrary code execution on install). It could also be used for downgrade attacks by only changing the version. This issue has been addressed in commit 6853e2642df which is included in release version 2.9.4. Users are advised to upgrade. There are no known workarounds for this vulnerability.

CVSS Base Scores

version 3.1