CVE-2026-50735 Affecting pglogical package, versions <2.4.8


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.38% (29th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PGLOGICAL-18388461
  • published29 Jul 2026
  • disclosed28 Jul 2026

Introduced: 28 Jul 2026

CVE-2026-50735  (opens in a new tab)

How to fix?

Upgrade Echo:latest pglogical to version 2.4.8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pglogical package and not the pglogical package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

pglogical's apply worker does not sufficiently validate the length of certain fields in incoming replication protocol messages before copying them, resulting in an out-of-bounds read. A party acting as the publisher for a subscription, for example a non-PostgreSQL endpoint that speaks the pglogical replication protocol, can return crafted messages that cause the subscriber's apply worker to read beyond the bounds of an allocated buffer, disclosing adjacent process memory or crashing the worker. To exploit the issue an attacker must be able to direct a subscription at an endpoint they control. In default installations this requires privileges normally reserved for a superuser, so the issue is most relevant to managed deployments where the ability to create subscriptions has been delegated to non-superuser roles.

CVSS Base Scores

version 3.1