CVE-2026-50737 Affecting pglogical package, versions <2.4.8


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.4% (32nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PGLOGICAL-18388463
  • published29 Jul 2026
  • disclosed28 Jul 2026

Introduced: 28 Jul 2026

CVE-2026-50737  (opens in a new tab)

How to fix?

Upgrade Echo:latest pglogical to version 2.4.8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pglogical package and not the pglogical package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

When applying replicated changes for a row that is missing one or more columns, pglogical evaluates the affected table's default expressions on the subscriber. Because the apply worker runs at a privilege level equivalent to a PostgreSQL superuser in default installations, any function invoked by such a default expression also runs at that privilege. A party acting as the publisher can use this path to cause functions to be executed on the subscriber as superuser, escalating from a role permitted to use pglogical to full superuser.

This is a second, independent path to the same superuser escalation tracked under CVE-2026-50736 (the pglogical queue issue). To exploit the issue an attacker must be able to direct a subscription at an endpoint they control. In default installations this requires privileges normally reserved for a superuser, so the issue is most relevant to managed deployments where the ability to create subscriptions has been delegated to non-superuser roles.

CVSS Base Scores

version 3.1