CVE-2024-9026 Affecting php-7.2 package, versions <7.2.34+e1


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.49% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PHP72-21716708
  • published26 Oct 2026
  • disclosed8 Oct 2024

Introduced: 8 Oct 2024

CVE-2024-9026  (opens in a new tab)

How to fix?

Upgrade Echo:latest php-7.2 to version 7.2.34+e1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-7.2 package and not the php-7.2 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

In PHP versions 8.1.* before 8.1.30, 8.2.* before 8.2.24, 8.3.* before 8.3.12, when using PHP-FPM SAPI and it is configured to catch workers output through catch_workers_output = yes, it may be possible to pollute the final log or remove up to 4 characters from the log messages by manipulating log message content. Additionally, if PHP-FPM is configured to use syslog output, it may be possible to further remove log data using the same vulnerability.

CVSS Base Scores

version 3.1