NULL Pointer Dereference Affecting php-7.2 package, versions <7.2.34+e1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.15% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PHP72-21716728
  • published26 Oct 2026
  • disclosed15 Feb 2021

Introduced: 15 Feb 2021

CVE-2021-21702  (opens in a new tab)
CWE-476  (opens in a new tab)

How to fix?

Upgrade Echo:latest php-7.2 to version 7.2.34+e1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-7.2 package and not the php-7.2 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

In PHP versions 7.3.x below 7.3.27, 7.4.x below 7.4.15 and 8.0.x below 8.0.2, when using SOAP extension to connect to a SOAP server, a malicious SOAP server could return malformed XML data as a response that would cause PHP to access a null pointer and thus cause a crash.

CVSS Base Scores

version 3.1