Use After Free Affecting php-7.2 package, versions <7.2.34+e1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PHP72-21716734
  • published26 Oct 2026
  • disclosed27 Feb 2022

Introduced: 27 Feb 2022

CVE-2021-21708  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Echo:latest php-7.2 to version 7.2.34+e1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-7.2 package and not the php-7.2 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

In PHP versions 7.4.x below 7.4.28, 8.0.x below 8.0.16, and 8.1.x below 8.1.3, when using filter functions with FILTER_VALIDATE_FLOAT filter and min/max limits, if the filter fails, there is a possibility to trigger use of allocated memory after free, which can result it crashes, and potentially in overwrite of other memory chunks and RCE. This issue affects: code that uses FILTER_VALIDATE_FLOAT with min/max limits.

CVSS Base Scores

version 3.1