Out-of-bounds Write Affecting php-7.2 package, versions <7.2.34+e1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.14% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PHP72-21716737
  • published26 Oct 2026
  • disclosed28 Jul 2022

Introduced: 28 Jul 2022

CVE-2022-31627  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Echo:latest php-7.2 to version 7.2.34+e1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-7.2 package and not the php-7.2 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

In PHP versions 8.1.x below 8.1.8, when fileinfo functions, such as finfo_buffer, due to incorrect patch applied to the third party code from libmagic, incorrect function may be used to free allocated memory, which may lead to heap corruption.

CVSS Base Scores

version 3.1