Resource Exhaustion Affecting phpmyadmin package, versions <4:5.0.4+dfsg2-2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.57% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PHPMYADMIN-22113806
  • published1 Nov 2026
  • disclosed13 Jan 2021

Introduced: 13 Jan 2021

CVE-2021-21252  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Echo:latest phpmyadmin to version 4:5.0.4+dfsg2-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream phpmyadmin package and not the phpmyadmin package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

The jQuery Validation Plugin provides drop-in validation for your existing forms. It is published as an npm package "jquery-validation". jquery-validation before version 1.19.3 contains one or more regular expressions that are vulnerable to ReDoS (Regular Expression Denial of Service). This is fixed in 1.19.3.

CVSS Base Scores

version 3.1