Directory Traversal Affecting phpsysinfo package, versions <3.2.5-3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
5.57% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PHPSYSINFO-19427280
  • published29 Aug 2026
  • disclosed6 Jul 2006

Introduced: 6 Jul 2006

CVE-2006-3360  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Echo:latest phpsysinfo to version 3.2.5-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream phpsysinfo package and not the phpsysinfo package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

Directory traversal vulnerability in index.php in phpSysInfo 2.5.1 allows remote attackers to determine the existence of arbitrary files via a .. (dot dot) sequence and a trailing null (%00) byte in the lng parameter, which will display a different error message if the file exists.

CVSS Base Scores

version 3.1