CVE-2007-4048 Affecting phpsysinfo package, versions <2.5.1-6.1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.32% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PHPSYSINFO-19427281
  • published29 Aug 2026
  • disclosed30 Jul 2007

Introduced: 30 Jul 2007

CVE-2007-4048  (opens in a new tab)

How to fix?

Upgrade Echo:latest phpsysinfo to version 2.5.1-6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream phpsysinfo package and not the phpsysinfo package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

Cross-site scripting (XSS) vulnerability in index.php in phpSysInfo 2.5.4-dev and earlier allows remote attackers to inject arbitrary web script or HTML via the PATH_INFO.

CVSS Base Scores

version 3.1