Incorrect Authorization Affecting php-twig package, versions <3.27.0-0+deb13u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.33% (26th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PHPTWIG-17982251
  • published15 Jul 2026
  • disclosed14 Jul 2026

Introduced: 14 Jul 2026

CVE-2026-46635  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade Echo:latest php-twig to version 3.27.0-0+deb13u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-twig package and not the php-twig package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

Twig is a template language for PHP. Prior to 3.26.0, the column filter passes object arrays to PHP array_column(), which reads public and magic properties without reaching CoreExtension::getAttribute() or SandboxExtension::checkPropertyAllowed(), allowing an untrusted template author with column in allowedFilters to read properties that are not in the sandbox allowlist. This issue is fixed in version 3.26.0.

CVSS Base Scores

version 3.1