Cross-site Scripting (XSS) Affecting php-twig package, versions <3.5.1-1+deb12u3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.3% (22nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PHPTWIG-17982259
  • published15 Jul 2026
  • disclosed14 Jul 2026

Introduced: 14 Jul 2026

CVE-2026-47730  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Echo:latest php-twig to version 3.5.1-1+deb12u3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-twig package and not the php-twig package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

Twig is a template language for PHP. From 3.0.0 until 3.26.0, Twig\Profiler\Dumper\HtmlDumper writes Profile::getTemplate() and Profile::getName() into HTML output without escaping, allowing attacker-controlled template or profile names to inject arbitrary HTML when a browser renders the profiler dump. This issue is fixed in version 3.26.0.

CVSS Base Scores

version 3.1