Out-of-Bounds Affecting ppp package, versions <2.5.0-1+2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.89% (59th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PPP-20028281
  • published21 Sept 2026
  • disclosed18 Dec 2022

Introduced: 18 Dec 2022

CVE-2022-4603  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Echo:latest ppp to version 2.5.0-1+2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ppp package and not the ppp package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

A vulnerability classified as problematic has been found in ppp. Affected is the function dumpppp of the file pppdump/pppdump.c of the component pppdump. The manipulation of the argument spkt.buf/rpkt.buf leads to improper validation of array index. The real existence of this vulnerability is still doubted at the moment. The name of the patch is a75fb7b198eed50d769c80c36629f38346882cbf. It is recommended to apply a patch to fix this issue. VDB-216198 is the identifier assigned to this vulnerability. NOTE: pppdump is not used in normal process of setting up a PPP connection, is not installed setuid-root, and is not invoked automatically in any scenario.

CVSS Base Scores

version 3.1