Improper Input Validation Affecting pulseaudio package, versions <0.9.9-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.56% (42nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PULSEAUDIO-18480776
  • published31 Jul 2026
  • disclosed29 Jan 2008

Introduced: 29 Jan 2008

CVE-2008-0008  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Echo:latest pulseaudio to version 0.9.9-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pulseaudio package and not the pulseaudio package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

The pa_drop_root function in PulseAudio 0.9.8, and a certain 0.9.9 build, does not check return values from (1) setresuid, (2) setreuid, (3) setuid, and (4) seteuid calls when attempting to drop privileges, which might allow local users to gain privileges by causing those calls to fail via attacks such as resource exhaustion.

CVSS Base Scores

version 3.1