Inefficient Regular Expression Complexity Affecting python-markdown2 package, versions <2.3.10-1.1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.32% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PYTHONMARKDOWN2-21004965
  • published16 Oct 2026
  • disclosed3 Mar 2021

Introduced: 3 Mar 2021

CVE-2021-26813  (opens in a new tab)
CWE-1333  (opens in a new tab)

How to fix?

Upgrade Echo:latest python-markdown2 to version 2.3.10-1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-markdown2 package and not the python-markdown2 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

markdown2 >=1.0.1.18, fixed in 2.4.0, is affected by a regular expression denial of service vulnerability. If an attacker provides a malicious string, it can make markdown2 processing difficult or delayed for an extended period of time.

CVSS Base Scores

version 3.1