Link Following Affecting python-rply package, versions <0.7.4-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.39% (32nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-PYTHONRPLY-21707411
  • published25 Oct 2026
  • disclosed21 Nov 2019

Introduced: 21 Nov 2019

CVE-2014-1938  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade Echo:latest python-rply to version 0.7.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-rply package and not the python-rply package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

python-rply before 0.7.4 insecurely creates temporary files.

CVSS Base Scores

version 3.1