Access Restriction Bypass Affecting radsecproxy package, versions <1.6.2-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.76% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-RADSECPROXY-20153808
  • published26 Sept 2026
  • disclosed20 Nov 2012

Introduced: 20 Nov 2012

CVE-2012-4523  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Echo:latest radsecproxy to version 1.6.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream radsecproxy package and not the radsecproxy package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

radsecproxy before 1.6.1 does not properly verify certificates when there are configuration blocks with CA settings that are unrelated to the block being used for verifying the certificate chain, which might allow remote attackers to bypass intended access restrictions and spoof clients.

CVSS Base Scores

version 3.1