CVE-2015-2296 Affecting requests package, versions <2.4.3-6


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.18% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-REQUESTS-18067259
  • published21 Jul 2026
  • disclosed18 Mar 2015

Introduced: 18 Mar 2015

CVE-2015-2296  (opens in a new tab)

How to fix?

Upgrade Echo:latest requests to version 2.4.3-6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream requests package and not the requests package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

The resolve_redirects function in sessions.py in requests 2.1.0 through 2.5.3 allows remote attackers to conduct session fixation attacks via a cookie without a host value in a redirect.

CVSS Base Scores

version 3.1