Arbitrary Code Injection Affecting ruby3.1 package, versions <3.1.2-4


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.45% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-RUBY31-21707421
  • published25 Oct 2026
  • disclosed18 Nov 2022

Introduced: 18 Nov 2022

CVE-2021-33621  (opens in a new tab)
CWE-74  (opens in a new tab)

How to fix?

Upgrade Echo:latest ruby3.1 to version 3.1.2-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby3.1 package and not the ruby3.1 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

The cgi gem before 0.1.0.2, 0.2.x before 0.2.2, and 0.3.x before 0.3.5 for Ruby allows HTTP response splitting. This is relevant to applications that use untrusted user input either to generate an HTTP response or to create a CGI::Cookie object.

CVSS Base Scores

version 3.1