Cross-site Scripting (XSS) Affecting ruby-loofah package, versions <2.2.1-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.93% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-RUBYLOOFAH-18751749
  • published13 Aug 2026
  • disclosed27 Mar 2018

Introduced: 27 Mar 2018

CVE-2018-8048  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Echo:latest ruby-loofah to version 2.2.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-loofah package and not the ruby-loofah package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

In the Loofah gem through 2.2.0 for Ruby, non-whitelisted HTML attributes may occur in sanitized output by republishing a crafted HTML fragment.