Uncontrolled Recursion Affecting ruby-loofah package, versions <2.19.1-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.17% (67th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-RUBYLOOFAH-18751754
  • published13 Aug 2026
  • disclosed14 Dec 2022

Introduced: 14 Dec 2022

CVE-2022-23516  (opens in a new tab)
CWE-674  (opens in a new tab)

How to fix?

Upgrade Echo:latest ruby-loofah to version 2.19.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-loofah package and not the ruby-loofah package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.2.0, < 2.19.1 uses recursion for sanitizing CDATA sections, making it susceptible to stack exhaustion and raising a SystemStackError exception. This may lead to a denial of service through CPU resource consumption. This issue is patched in version 2.19.1. Users who are unable to upgrade may be able to mitigate this vulnerability by limiting the length of the strings that are sanitized.

CVSS Base Scores

version 3.1