Cryptographic Issues Affecting ruby-rack package, versions <1.4.0-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.87% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-RUBYRACK-18307118
  • published25 Jul 2026
  • disclosed30 Dec 2011

Introduced: 30 Dec 2011

CVE-2011-5036  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade Echo:latest ruby-rack to version 1.4.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-rack package and not the ruby-rack package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

Rack before 1.1.3, 1.2.x before 1.2.5, and 1.3.x before 1.3.6 computes hash values for form parameters without restricting the ability to trigger hash collisions predictably, which allows remote attackers to cause a denial of service (CPU consumption) by sending many crafted parameters.

CVSS Base Scores

version 3.1