CVE-2013-0263 Affecting ruby-rack package, versions <1.4.1-2.1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
5.38% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-RUBYRACK-18307123
  • published25 Jul 2026
  • disclosed8 Feb 2013

Introduced: 8 Feb 2013

CVE-2013-0263  (opens in a new tab)

How to fix?

Upgrade Echo:latest ruby-rack to version 1.4.1-2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-rack package and not the ruby-rack package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

Rack::Session::Cookie in Rack 1.5.x before 1.5.2, 1.4.x before 1.4.5, 1.3.x before 1.3.10, 1.2.x before 1.2.8, and 1.1.x before 1.1.6 allows remote attackers to guess the session cookie, gain privileges, and execute arbitrary code via a timing attack involving an HMAC comparison function that does not run in constant time.

CVSS Base Scores

version 3.1