Inefficient Regular Expression Complexity Affecting ruby-rack package, versions <2.2.4-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.23% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-RUBYRACK-18307129
  • published25 Jul 2026
  • disclosed5 Dec 2022

Introduced: 5 Dec 2022

CVE-2022-30122  (opens in a new tab)
CWE-1333  (opens in a new tab)

How to fix?

Upgrade Echo:latest ruby-rack to version 2.2.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-rack package and not the ruby-rack package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

A possible denial of service vulnerability exists in Rack <2.0.9.1, <2.1.4.1 and <2.2.3.1 in the multipart parsing component of Rack.

CVSS Base Scores

version 3.1