CVE-2023-34237 Affecting sabnzbdplus package, versions <4.0.2+dfsg-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.73% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-SABNZBDPLUS-19012642
  • published20 Aug 2026
  • disclosed7 Jun 2023

Introduced: 7 Jun 2023

CVE-2023-34237  (opens in a new tab)

How to fix?

Upgrade Echo:latest sabnzbdplus to version 4.0.2+dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sabnzbdplus package and not the sabnzbdplus package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

SABnzbd is an open source automated Usenet download tool. A design flaw was discovered in SABnzbd that could allow remote code execution. Manipulating the Parameters setting in the Notification Script functionality allows code execution with the privileges of the SABnzbd process. Exploiting the vulnerabilities requires access to the web interface. Remote exploitation is possible if users[exposed their setup to the internet or other untrusted networks without setting a username/password. By default SABnzbd is only accessible from localhost, with no authentication required for the web interface. This issue has been patched in commits e3a722 and 422b4f which have been included in the 4.0.2 release. Users are advised to upgrade. Users unable to upgrade should ensure that a username and password have been set if their instance is web accessible.

CVSS Base Scores

version 3.1