Improper Handling of Exceptional Conditions Affecting simplesamlphp package, versions <1.8.1-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.74% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-SIMPLESAMLPHP-18016445
  • published19 Jul 2026
  • disclosed6 Nov 2019

Introduced: 6 Nov 2019

CVE-2011-4625  (opens in a new tab)
CWE-755  (opens in a new tab)

How to fix?

Upgrade Echo:latest simplesamlphp to version 1.8.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream simplesamlphp package and not the simplesamlphp package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt or forge messages.

CVSS Base Scores

version 3.1