Improper Input Validation Affecting simplesamlphp package, versions <1.14.11-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.18% (67th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-SIMPLESAMLPHP-18016450
  • published19 Jul 2026
  • disclosed17 Feb 2017

Introduced: 17 Feb 2017

CVE-2016-9955  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Echo:latest simplesamlphp to version 1.14.11-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream simplesamlphp package and not the simplesamlphp package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

The SimpleSAML_XML_Validator class constructor in SimpleSAMLphp before 1.14.11 might allow remote attackers to spoof signatures on SAML 1 responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.