Session Fixation Affecting simplesamlphp package, versions <1.14.15-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.13% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-SIMPLESAMLPHP-18016460
  • published19 Jul 2026
  • disclosed1 Sept 2017

Introduced: 1 Sep 2017

CVE-2017-12868  (opens in a new tab)
CWE-384  (opens in a new tab)

How to fix?

Upgrade Echo:latest simplesamlphp to version 1.14.15-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream simplesamlphp package and not the simplesamlphp package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

The secureCompare method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.13 and earlier, when used with PHP before 5.6, allows attackers to conduct session fixation attacks or possibly bypass authentication by leveraging missing character conversions before an XOR operation.