Session Fixation Affecting simplesamlphp package, versions <1.14.11-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.66% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-SIMPLESAMLPHP-18016465
  • published19 Jul 2026
  • disclosed1 Sept 2017

Introduced: 1 Sep 2017

CVE-2017-12873  (opens in a new tab)
CWE-384  (opens in a new tab)

How to fix?

Upgrade Echo:latest simplesamlphp to version 1.14.11-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream simplesamlphp package and not the simplesamlphp package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

SimpleSAMLphp 1.7.0 through 1.14.10 might allow attackers to obtain sensitive information, gain unauthorized access, or have unspecified other impacts by leveraging incorrect persistent NameID generation when an Identity Provider (IdP) is misconfigured.