Double Free Affecting slurm-wlm package, versions <22.05.8-4+deb12u2


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.38% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-SLURMWLM-19512374
  • published3 Sept 2026
  • disclosed14 Dec 2023

Introduced: 14 Dec 2023

CVE-2023-49937  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade Echo:latest slurm-wlm to version 22.05.8-4+deb12u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-wlm package and not the slurm-wlm package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

An issue was discovered in SchedMD Slurm 22.05.x, 23.02.x, and 23.11.x. Because of a double free, attackers can cause a denial of service or possibly execute arbitrary code. The fixed versions are 22.05.11, 23.02.7, and 23.11.1.

CVSS Base Scores

version 3.1