Out-of-bounds Write Affecting sqlite3 package, versions <3.46.1-7+e9


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.18% (9th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-SQLITE3-22113839
  • published1 Nov 2026
  • disclosed30 Oct 2026

Introduced: 30 Oct 2026

NewCVE-2026-119379  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Echo:latest sqlite3 to version 3.46.1-7+e9 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sqlite3 package and not the sqlite3 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

SQLite before 3.54.0 built with the session extension contains a heap buffer overflow vulnerability in sqlite3changeset_apply() that allows attackers to corrupt heap memory by supplying crafted changesets. Attackers can repeat a table name in a second changeset block with a larger column count, causing sessionUpdateFind() to memset past the undersized aUpdateMask allocation.

CVSS Base Scores

version 3.1