Improper Authentication Affecting strongswan package, versions <4.6.4-7


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.59% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-STRONGSWAN-19643859
  • published8 Sept 2026
  • disclosed2 May 2013

Introduced: 2 May 2013

CVE-2013-2944  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Echo:latest strongswan to version 4.6.4-7 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream strongswan package and not the strongswan package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

strongSwan 4.3.5 through 5.0.3, when using the OpenSSL plugin for ECDSA signature verification, allows remote attackers to authenticate as other users via an invalid signature.

CVSS Base Scores

version 3.1