Cache Poisoning Affecting code.cloudfoundry.org/grootfs/fetcher/layer_fetcher package, versions >=0.3.0 <0.30.0


0.0
high

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
7.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-CODECLOUDFOUNDRYORGGROOTFSFETCHERLAYERFETCHER-50057
  • published 25 Dec 2017
  • disclosed 13 Nov 2017
  • credit GrootFS Team

Overview

grootfs is the Cloud Foundry component that provides filesystem isolation for containers and deals with container (Docker and OCI) images.

Affected versions of this package are vulnerable to Cache Poisoning.

Cloud Foundry Foundation GrootFS release 0.3.x versions prior to 0.30.0 do not validate DiffIDs, allowing specially crafted images to poison the grootfs volume cache. For example, this could allow an attacker to provide an image layer that GrootFS would consider to be the Ubuntu base layer.