Information Exposure Affecting code.gitea.io/gitea/routers package, versions <1.7.0


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.05% (63rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-GOLANG-CODEGITEAIOGITEAROUTERS-2396327
  • published9 Feb 2022
  • disclosed9 Feb 2022
  • creditzeripath

Introduced: 9 Feb 2022

CVE-2021-45325  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade code.gitea.io/gitea/routers to version 1.7.0 or higher.

Overview

code.gitea.io/gitea/routers is a project that makes the easiest, fastest, and most painless way of setting up a self-hosted Git service

Affected versions of this package are vulnerable to Information Exposure of local network data through the raw OpenID errors provided by the UI.

CVSS Base Scores

version 3.1