Access Control Bypass Affecting code.gitea.io/gitea/routers/repo Open this link in a new tab package, versions <1.6.3


0.0
medium
  • Attack Complexity

    Low

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-CODEGITEAIOGITEAROUTERSREPO-2841489

  • published

    22 May 2022

  • disclosed

    23 Aug 2020

  • credit

    Unknown

How to fix?

Upgrade code.gitea.io/gitea/routers/repo to version 1.6.3 or higher.

Overview

Affected versions of this package are vulnerable to Access Control Bypass in the Delete/Edit file functionality that can result in the attacker deleting files outside the repository they have access to. This attack appears to be exploitable via the attacker must get write access to "any" repository including self-created ones.

References