Path Traversal Affecting github.com/0xjacky/nginx-ui package, versions <2.0.0-beta.12


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.71% (52nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Path Traversal vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-GOLANG-GITHUBCOM0XJACKYNGINXUI-6209594
  • published30 Jan 2024
  • disclosed30 Jan 2024
  • creditElleuch-x1

Introduced: 30 Jan 2024

CVE-2024-23827  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade github.com/0xJacky/Nginx-UI to version 2.0.0-beta.12 or higher.

Overview

github.com/0xJacky/Nginx-UI is a yet another Nginx Web UI, developed by 0xJacky and Hintay.

Affected versions of this package are vulnerable to Path Traversal via the Import Certificate feature. An attacker can overwrite arbitrary files on the system by providing crafted user input that is not properly validated as a certificate or key, potentially leading to remote code execution by overwriting critical configuration files such as app.ini.

CVSS Base Scores

version 3.1