Improper Input Validation Affecting github.com/apache/thrift/lib/go/thrift package, versions >=0.9.3 <0.13.0


0.0
medium
  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMAPACHETHRIFTLIBGOTHRIFT-474612

  • published

    30 Oct 2019

  • disclosed

    16 Oct 2019

  • credit

    Alexandre Fiori

How to fix?

Upgrade github.com/apache/thrift/lib/go/thrift to version 0.13.0 or higher.

Overview

github.com/apache/thrift/lib/go/thrift is a Go implementation of the Apache Thrift library.

Affected versions of this package are vulnerable to Improper Input Validation. None