Improper Input Validation Affecting github.com/apache/trafficcontrol/lib/go-tc Open this link in a new tab package, versions <5.1.3


0.0
high
  • Attack Complexity

    Low

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMAPACHETRAFFICCONTROLLIBGOTC-1730330

  • published

    12 Oct 2021

  • disclosed

    12 Oct 2021

  • credit

    Unknown

How to fix?

Upgrade github.com/apache/trafficcontrol/lib/go-tc to version 5.1.3 or higher.

Overview

github.com/apache/trafficcontrol/lib/go-tc is a provides structures, constants, and functions that are used throughout the components of Apache Traffic Control.

Affected versions of this package are vulnerable to Improper Input Validation. An authenticated user with Portal-level privileges can send a request with a specially-crafted email subject to the /deliveryservices/request Traffic Ops endpoint to send an email, from the Traffic Ops server, with an arbitrary body to any email address.