Cross-site Scripting (XSS) Affecting github.com/argoproj/argo-cd/cmd Open this link in a new tab package, versions <1.7.13 >=1.8.0 <1.8.6


0.0
medium
  • Attack Complexity

    Low

  • Privileges Required

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMARGOPROJARGOCDCMD-1078291

  • published

    3 Mar 2021

  • disclosed

    22 Feb 2021

  • credit

    jannfis

How to fix?

Upgrade github.com/argoproj/argo-cd/cmd to version 1.7.13, 1.8.6 or higher.

Overview

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) the SSO provider connected to Argo CD would have to send back a malicious error message containing JavaScript to the user.

References