Improper Authentication Affecting github.com/argoproj/argo-cd/util/cache package, versions <1.5.1


0.0
high

Snyk CVSS

    Attack Complexity Low
    Integrity High
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMARGOPROJARGOCDUTILCACHE-565378
  • published 14 Apr 2020
  • disclosed 8 Apr 2020
  • credit Matt Hamilton of https://soluble.ai

How to fix?

Upgrade github.com/argoproj/argo-cd/util/cache to version 1.5.1 or higher.

Overview

github.com/argoproj/argo-cd/util/cache is a declarative, GitOps continuous delivery tool for Kubernetes.

Affected versions of this package are vulnerable to Improper Authentication. The Argo API does not implement anti-automation measures such as rate limiting, account lockouts, or other anti-bruteforce measures. Attackers can submit an unlimited number of authentication attempts without consequence.