User Enumeration Affecting github.com/argoproj/argo-cd/util/session package, versions >=1.5.0 <1.5.1


0.0
medium

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.1% (40th percentile)
Expand this section
NVD
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMARGOPROJARGOCDUTILSESSION-564997
  • published 9 Apr 2020
  • disclosed 9 Apr 2020
  • credit Unknown

How to fix?

Upgrade github.com/argoproj/argo-cd/util/session to version 1.5.1 or higher.

Overview

github.com/argoproj/argo-cd/util/session is a Declarative continuous deployment for Kubernetes.

Affected versions of this package are vulnerable to User Enumeration. It is possible for attackers to determine the usernames of valid (non-SSO) accounts within Argo.