Improper Access Control Affecting Open this link in a new tab package, versions >=0.6.1 <2.1.15 >=2.2.8 <2.2.9 >=2.3.3 <2.3.4

  • Attack Complexity


  • User Interaction


Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id


  • published

    19 May 2022

  • disclosed

    18 May 2022

  • credit

    Naufal Septiadi

How to fix?

Upgrade to version 2.1.15, 2.2.9, 2.3.4 or higher.

Overview is a declarative, GitOps continuous delivery tool for Kubernetes.

Affected versions of this package are vulnerable to Improper Access Control due to the possibility of an attacker spoofing error messages via the login screen, when SSO is enabled. In order to exploit this vulnerability, an attacker would have to trick the victim to visit a specially crafted URL that contains the message to be displayed.