Improper Authentication Affecting github.com/authelia/authelia/internal/handlers Open this link in a new tab package, versions >=4.0.0-alpha1 <4.29.3


0.0
critical
  • Attack Complexity

    Low

  • Scope

    Changed

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMAUTHELIAAUTHELIAINTERNALHANDLERS-1298044

  • published

    30 May 2021

  • disclosed

    30 May 2021

  • credit

    Siemens Energy

How to fix?

Upgrade github.com/authelia/authelia/internal/handlers to version 4.29.3 or higher.

Overview

Affected versions of this package are vulnerable to Improper Authentication via a crafted HTTP request that can bypass the authentication mechanism. NOTE: this is known to affect nginx ngx_http_auth_request_module users.