Access Control Bypass Affecting github.com/authzed/spicedb/internal/services package, versions >=1.3.0 <1.4.0


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
Expand this section
NVD
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMAUTHZEDSPICEDBINTERNALSERVICES-2336172
  • published 12 Jan 2022
  • disclosed 12 Jan 2022
  • credit Víctor Roldán Betancort

How to fix?

Upgrade github.com/authzed/spicedb/internal/services to version 1.4.0 or higher.

Overview

Affected versions of this package are vulnerable to Access Control Bypass via the intersection function of the Wildcard Relationship Handler component.