Access Control Bypass Affecting github.com/authzed/spicedb/pkg/validationfile Open this link in a new tab package, versions >=1.3.0 <1.4.0


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMAUTHZEDSPICEDBPKGVALIDATIONFILE-2336170

  • published

    12 Jan 2022

  • disclosed

    12 Jan 2022

  • credit

    Víctor Roldán Betancort

How to fix?

Upgrade github.com/authzed/spicedb/pkg/validationfile to version 1.4.0 or higher.

Overview

Affected versions of this package are vulnerable to Access Control Bypass via the intersection function of the Wildcard Relationship Handler component.